当前最新的WordPress 5.2版本已经开始要求用户使用PHP 5.6以上的环境了,估计很快就会要求最低PHP 7.0以上,这对于开发者来说确实是件好事情。

早前,一小部分主题巴巴客户在安装我们的WordP@ – t eress主题的时候可能会出现PHP错误(常见于Lin& m g B V wux主机):

或者直接就是HTTP 500错误(常见于Windows主机),导致网站无法打开:

这两个错误都是由于网站主机服务9 . K ( z / Q器环境的PHP版本太低导致的。由于我们的WordPress主题都是基于PHP 5.5以上的语法来开发的,所以低于PHP 5.5的主机环境会报错。登陆您的主机管理后台,或者联系主机商家,升级切换到PHP 5.5以上的版本(建议直接PHP 7.0+),这个问题就解决了c s g,网站就不错出现PHP错误代码,也不会出现HTTP 500报错了。

国内很多老旧主机还在使用的PHP 5.4环境已经不适合W2 0 oordPress了,既不安全,运行也慢。新版PHP在安全性和运行效率上有较大提升,建议所有用户直接升级主机环境到PHP 7.0以上,与时俱进,使用无忧。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注